加載共享庫時出錯:libcrypto.so.1


1

我剛剛在VMware中安裝了最新的Ubuntu 64位。我正在運行命令並收到此錯誤:

./ipsw: error while loading shared libraries: libcrypto.so.1: cannot open shared object file: No such file or directory

我進行了快速搜索,發現a few solution (i.e. install missing lib)This one,但是,在嘗試安裝它們時,我已經使用了最新版本。我該怎麼辦?

[email protected]:~$ sudo apt-get install libxss1
[sudo] password for ppp: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libxss1 is already the newest version (1:1.2.2-1).
0 upgraded, 0 newly installed, 0 to remove and 74 not upgraded.
[email protected]:~$ sudo aptitude search libXss
sudo: aptitude: command not found
[email protected]:~$ 
2

The file libcrypto.so.1.0.0 is provided by a package called libssl1.0.0.

So to install that package which provides the file you need, run:

sudo apt install libssl1.0.0

However, it seems like your application expects it with a different name, libssl.so.1, which means we have to create a link for that, similar to the procedure here:

cd /lib/x86_64-linux-gnu
sudo ln -s libcrypto.so.1.0.0 libcrypto.so.1