Dépendances non satisfaites (botter mon BUTT)


0

Un problème s'est produit lors d'une mise à niveau.Je ne sais pas quoi.Le résultat des mises à niveau ultérieures est indiqué ci-dessous.J'ai essayé le apt --fix-broken install sans succès.J'ai répertorié cette sortie par la suite.

$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libglvnd-dev : Depends: libglvnd0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libglvnd-core-dev (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libegl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libgles2 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libgl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libglx0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libopengl0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

$ apt --fix-broken install
Do you want to continue? [Y/n] 
(Reading database ... 469780 files and directories currently installed.)
Preparing to unpack .../libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.106-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb
 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
0

Your key problem is this:

trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3

This happens occasionally. You must choose between libgles1 and nvidia-340 340.106-0ubuntu3. apt remove one of them and then complete the install.

Being as this is the nvidia package, you may see an effect on your desktop but with failsafe X, you shouldn't end up with no GUI at all. It will just look strange until you reinstall the nvidia drivers.

Once you have resolved the conflict and done an apt update you may be able to get them both installed, but that depends on whether these packages are truly compatible on the one system, and that can also depend on where you got them from.

More dangerous solution

If it's really the only way, delete the file /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 and attempt a apt -f install. Beware, though, that this means that your system will be in an untested state, and you should, at the very least, run a system checksum test to ensure every file is where it should be.


0

I found this after posting all the fault into search. His answer corrected my issue but I had to do the second command instruction before the first. I am now clean updated and relieved. My second choice was to wait until the 18th and do a full install when 18.10 deploys.

Broken apt, can't update libglvnd due to unmet dependencies (Nvidia)